第 2 节

嘉立创EDA入门

作者
张益豪的头像张益豪
协作者
董佳辉的头像董佳辉
发布于 2023/10/09更新于 2026/08/20

1.下载与安装嘉立创EDA

学习00-1视频(【嘉立创EDA-PCB设计零基础入门课程(54集全)】https://www.bilibili.com/video/BV1fM411Z7cW?p=2&vd_source=c6b5a93fb5eed6f47c345ad502812aea

嘉立创EDA入门重点就是本视频合集,称为xx-x视频,没有要求学习的视频也可以简单了解一下,后续不再赘述)

官网安装好后还须激活,详细如上视频。

2.了解PCB相关基础知识

2.1什么是PCB板?PCB板的结构是什么?何为过孔?

学习01-0视频、01-1视频、01-2视频。

我们都做过初中物理的电路实验,但用导线连接的方式比较繁琐,而且容易出错,为了方便接线,便出现了PCB板。PCB板上面可以放置电阻、电容、等等元器件,PCB本身表面铜皮就代表导线。当一层板不能满足布线时,便出现了多层板,板与板之间就用过孔连接。

2.2何为元器件符号?什么是焊盘?什么是封装?

学习视频01-3视频。

2.2.1元器件符号

元器件符号初中大家就接触过,大家对电阻的印象最深,就是一个矩形,用矩形来代表电阻,称它为元器件符号。

电阻公认元器件符号是矩形,后续还会讲到,你可以绘制自己的元器件符号,也可以用菱形代表电阻。一般情况下,我们不会绘制元器件符号。

2.2.2焊盘

以灯泡为例,连接灯泡需要两根导线,一根接正极另一根接负极。导线在PCB中就成了铜皮,导线与灯泡连接处的地方,在PCB中称为焊盘。焊盘可以是各种各样,如点状、矩形等等,焊盘也可以自己绘制。

2.2.3封装

电阻有直插式、贴片,它们接入PCB的方式不同,焊盘不同,把这种不同以封装的不同区分。以贴片电阻为例,可大可小,但0603这种封装就是指一种大小的电阻,0805封装的电阻就比0603大,小封装的器件可能焊在大封装的焊盘,反之则不行,所以选好封装至关重要。

2.3小结——PCB板元素构成

学习01-4视频

3.新建及完成工程——以GD32F103C8T6核心板为例

3.1熟悉嘉立创EDA

学习02-0视频;了解02-1视频、03-0视频。

3.1.1路径设置

一个完整的工程分为工程路径和库路径。工程路径存放的是原理图(所有元器件符号的集合而成的整体)和PCB(所有封装的集合所成的集体),而库路径存放的是某一个元器件或封装,如电阻的元器件符号、贴片电容1206的封装、贴片电阻0603的封装。

最重要的是工程路径,日后可从这里打开工程(当然创建了快捷方式就更方便了),由于我们使用***半离线模式,***都从嘉立创在线库中找元器件和封装。

3.1.2PCB设计流程

  1. 在嘉立创在线库找到工程所需的元器件符号和封装。

  2. 新建工程,将元器件放置在原理图中,并完成各器件之间的走线。

  3. 转换原理图到PCB。

  4. 完成PCB器件放置及走线。

  5. 导出Gerber文件并下单。

(6.完成焊接及测试)。

了解03-0视频,知道本次学习的最终目标,自此PCB设计正式开始。

3.2新建工程及准备工作

学习04-0视频。

3.2.1新建工程文件

依次:文件—>新建—>工程。工程路径一定要记清,名称以后还可重命名。

3.2.2新建元件库及器件(了解)

依次:文件—>新建—>元件库。(只有新建元件库后才能新建元件)

新建元件:文件—>新建—>元件。新建元件可以选择不同元件库;元件自己认识即可(最好小巧美观一点),起指示作用。

3.2.3绘制封装(了解)

学习05-0视频;了解05-1、05-2、05-3……05-11视频

新建封装也是建立在元件库的基础上,依次:文件—>新建—>封装。

从最上栏:工具—>封装管理器,进行器件与封装的批量关联。

3.2.4用立创商城选择合适的封装

3.2.2与3.2.3步骤比较繁琐,需要自己画器件与封装,耗时耗力。但嘉立创EDA这个软件解决了这个问题,他有非常大在线库,足够满足我们需求。

1.软件左栏常用库

4bb636fecb660ceb16f2b9735014380\.png

这里有常用的贴片电阻、电容、发光二极管的元件及封装。

2.有些特殊的元件需要到立创商城中寻找

e2733fdd11fb030f8a0e5cf3fb7d49a0\.png

长按往上拖动可以扩大该界面或点击弹出窗口,这是找元件的一种方法

35cb4e7d80f272fd3db5175ca68b68e\.png

点击开始页

688803cbe33cd6c78e5ed963da0eb8b\.png

从这个界面进入立创商城。

3.把器件放入工程中

d027a95cb01506ef546e15fedb74a7b\.png

复制这个生产商编号

image\.png

粘贴到这里,并放置到原理图中

3.3绘制原理图

绘制原理图一般采取“分—总”方法,即先画出每个模块,最后连接到一起。

3.3.1 5V转3V3电源模块绘制

学习04-1视频。

知道网络标签的作用,即两个相同的网络标签之间是相连的。

此降压模块常用,一定学会如何绘制。

3.3.2 USB输入模块绘制(了解)

了解04-2视频。

简单了解差分信号。保险丝一般不会使用,了解即可。

此模块可有可无,一般不画。

3.3.3 MCU主控绘制

学习04-3视频。

这部分主要是画滤波电容和引出信号引脚。

引出引脚的简单方法

e712dfd628bae7746f6d59335b1cd896\.png

鼠标左键按住往下拉,选中如上导线,Ctrl+C复制。

Ctrl+V粘贴,出现如下图,移动到合适引脚左击发放置(右击取消)。

4ec50d6ec758599e0a557c3783633477\.png

原理图绘制中可能出现很多类似这样的情况,要学会上述方法,可节省大量时间。

命名引脚方法参照3.3.6

3.3.4 晶振绘制

学习04-4视频。

3.3.5 复位按键绘制

学习04-5视频。

知道复位电路工作原理,该部分非常重要,不可省略。

3.3.6 扩展排针绘制

学习04-6视频。

引脚按照需求引出,一般不会全部引出。

引脚网络标签命名简单方法:

8af65844010bc11720fe159a7b474152\.png

ce3ab1bf233532443ae5f9e2b042e6da\.png

点击网络标签后,按Tab建,把名称改为PA1,后续放置就会按照标号顺序,PA1、PA2、PA3等。

左击放置,右击取消,再按Tab键继续重命名。

3.3.7原理图整理并检查

学习04-7视频、04-8视频;了解04-9视频。

原理图的分区并命名是个很好的习惯,便于自己与他人查看。

画完所有部分必须检查(最下栏),并改正错误,最好不要出现警告,如下图。

5dfb371cadb72c028cb6f665564507f1\.png

3.4 PCB布局及layout

当原理图没有任何问题时,才能进行以下步骤。

PCB Layout检查清单

以下检查项由原电路学习路线迁入,用于补充打板前的工程检查:

  1. 同一功能模块的器件尽量靠近,关键走线尽量短。

  2. 芯片去耦电容应靠近对应电源引脚,保证电流回路短而清晰。

  3. 高压差网络之间应满足安全间距,不能只按低压信号的间距处理。

  4. 根据持续电流、允许温升和铜厚确定电源线宽与过孔数量。

  5. 走线拐角避免锐角,优先使用钝角或圆弧。

  6. 高频或快速边沿信号避免长距离平行,注意串扰和回流路径。

  7. 接地优先保证连续参考平面,不要随意切割高速信号下方的地平面。

  8. 晶振、时钟和敏感模拟信号应远离开关电源、电机和大电流回路。

  9. 同类、有极性器件尽量统一方向,兼顾焊接、检查和维护。

  10. 接口、安装孔、指示灯、调试口和丝印应结合机械安装与线束方向检查。

完成布局布线后,还应检查原理图ERC、PCB DRC、未连接网络、极性、封装、接口方向、电源网络和板框尺寸。

3.4.1从原理图转到PCB

学习06-0视频、06-2视频;了解06-1视频。

再次强调,转PCB前一定确认原理图正确。

在原理图页面依次:设计—>更新/转换原理图到PCB。

一般只隐藏GND飞线,因为铺铜之后GND大全部连接完成。

板框绘制一定要加圆角,防止划伤。板框不能过大,嘉立创免费打板的规格是10x10cm。

3.4.2模块化预布局及精细布局

学习06-3视频、06-4视频。

一定要学会交互式布局(默认开着),在原理图上框选模块,到PCB布局自动高亮,且可整体拖动。

滤波电容要挨近芯片,晶振也要靠近芯片。

排针、案件、接口都要放在板子边缘。

电源流经顺序:大容值到小容值。

电容、电阻丝印直接写阻值、容值,例如,10K(不带单位的是电阻),100nf。

3.4.3 PCB布线

了解07-0视频;学习07-1视频、07-2视频、07-3视频。

3.4.3.1晶振走线处理:

包地,在晶振周围打地孔(详见视频);挖空处理,在晶振下方禁铺铜。

有时候我们省略包地处理,但挖空必须要!

常用的挖空处理:用多边形把晶振包起来,只选禁止铺铜且多层(选别的因间距问题经常报错)。

如下图:

67a1577ddecb94a477c498bcde57ecd8\.png

晶振走线要满足等长原则,即SOC_IN和SOC_OUT到其芯片引脚的线长相同。

最上栏依次:设计—>差分对管理器。

670a5ac57f8ab0c0cca692f852b1c478\.png

选上SOC_IN和SOC_OUT的芯片焊盘,添加差分对。

最上栏依次:布线—>等长调节。

image\.png

调节至符合规则即可,这是个错误示范,晶振走线通常走对称即可满足规则(如本节第一张图)。

07-2视频中以USB差分信号线详细讲了此过程。

3.4.3.2规范滤波电容走线

本视频的滤波电容不规范,正确布局如下。

image\.png

滤波电容要放在VCC附近,且电压先过电容再进VCC。

稳压模块的滤波电容也要如此。

3.4.3.3多路布线的应用

最上栏依次:布线—>多路布线。

image\.png

当多个引脚走法相似时,应用此法,大大提高效率。

3.4.3.4铺铜走电源线

能在一层走线就不要换层,信号线非必要不能换层,尽量让电源线换层给信号线走线空间。

5V、12V高一点的电压,走线尽量粗一点,用多边形铜皮可很好解决这个问题。

image\.png

这是一个示范,如图下面5V走线

71d8d3a2f191bd9324deb1fa73369d74\.png

8ac67fbfe0b44b3ff9659c65cbca98cf\.png

46c049a29469d5acce9fa3b14e2a5cf6\.png

调节好网络及焊盘连接方式(直连)。走线如下:

63c8fec42aff173f2e412bb1feb03653\.png

认真学习07-3视频。

学会该视频中的走线思路及处理。

3.4.3.5最后铺地铜

学习07-4视频、07-5视频。

铺铜规则:全填充、不保留孤岛。

最后进行DCR检查,把错误改正(如果不是多点接地,常常出现地线未连接)

3.4.3.6优化丝印

了解07-6视频、07-7视频。

推荐排针引脚、贴片电容、贴片电阻加丝印。

电容、电阻丝印直接写阻值、容值,例如,10K(不带单位的是电阻),100nf,方便后期焊接。

排针命名简单方法:

image\.png

线宽和高要调整到合适,推荐6mil和45mil。

image\.png

左击放置,右击取消。

image\.png

最后全选,换至顶层丝印即可。

4.免费打板

学习08-0视频。

4.1下载嘉立创下单助手

https://www.jlc.com/portal/appDownloadsWithConfig.html?init=android从在网站下载并安装。

4.2每月领取优惠卷

打开嘉立创下单助手,领取步骤如下:

25032a7413a9ecb08e9f82ad5e569f9a\.png

53a7da9e3bf793609c5a8ca9a9dbf454\.png

9036a1ed697f29e6af75c07c348838eb\.png

e7d62353a65677e785ce6651229689e1\.png

每月可领取两张,一定不能领取错了,仅限本月使用。

4.3导出PCB制板文件并下单

4.3.1导出Gerber文件

image\.png

9a089fe25ab757b4ead23d17aaf223af\.png

重命名Gerber文件并新建文件夹(专门存放Gerber文件)。

4.3.2下单

打开嘉立创下单助手,按如下图片步骤。

c8c416377b1d67b1690ba80a7333b361\.png

上传Gerber文件:

e7ce645a2e03c56c053ccd20eff188c0\.png

板子层数按需要选,板子数量为5:

1ff104dbb21047e41e206c0a7f8d4de3\.png

材质只能选FR-4:

893c8d3239b355d6fffc9318d058d450\.png

使用优惠卷并提交订单:

0963da0d0edb8eef7a2f00f91f7be6fe\.png

把红点选项都选好,但不要选择收费项,并点击提交订单:

2e65f79634f9a37904ed5b43b70fec39\.png

853690908cb3763b16fe469b8034124c\.png

当支付为0元时支付:

c5b1a48b7f7696099bcd9b240b0a3648\.png

4.3.3跟踪进度

了解08-1视频。

关注嘉立创微信公众号:

e0a5f53af2a227400640ca51481a6443\_720\.jpg

按以下步骤即可跟踪进度:

d29e672688697540a94a67b7fe27cab1\_720\.jpg

3ff069bcc60fa2370358e934bf705e54\_720\.jpg

至此,恭喜你完成了画板,打板!